[Infusion-users] Broken demo: Inline Edit

Bruce Smith oresmus at gmail.com
Tue Mar 30 18:13:03 UTC 2010


Hi,

There are no instructions visible for this demo:

http://build.fluidproject.org/infusion/demos/inlineEdit/simple/demo.html

See attached screenshot for what it looks like.

I'm using Firefox 3.6.2, Mac OS 10.5.8, and the NoScript plugin, but
NoScript reports it is not disabling anything on this site (and I believe
it, since the demo does work once I learn how to use it).

Maybe the lack of instructions is intentional, but I could not get it to
work until I read some archived mailing list posts, which led me to try the
tab key. Before reading that I was not able to edit anything (clicking on
bold words and typing did nothing, and nothing else I thought of trying
worked), and there were no error messages.

After trying some more, I realized that for most bold words, hovering over
them highlighted them, and clicking there made them editable -- but not for
the only ones I tried at first, namely the word "*bold*" itself in the lines
that say "The words in *bold* are editable"! I guess I only tried those
specific bold words, but that was enough to make me think it was "not
working". (And indeed the claim that all the bold words are editable is
wrong.) So this error is amusing in hindsight, but IMHO it needs fixing on
the page, either by making those words not bold or (preferably) by making
them editable. (And adding some instructions would be a good idea as well.)

- Bruce Smith
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://fluidproject.org/pipermail/infusion-users/attachments/20100330/cce627d3/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Picture 28.png
Type: image/png
Size: 140645 bytes
Desc: not available
URL: <http://fluidproject.org/pipermail/infusion-users/attachments/20100330/cce627d3/attachment.png>


More information about the Infusion-users mailing list