[Infusion-users] Broken demo: Inline Edit

Jess Mitchell jess at jessmitchell.com
Mon Apr 5 21:38:19 UTC 2010


While testing inline-edit for this next release I was reminded of this thread.  Another way to make the demo clearer, in addition to some instructions, would be to change the text that is bold so it shows the desired behaviour for an empty inline edit cell -- namely say Click here to edit rather than over the lazy dogs.

Best,
Jess


~~~~~~~~~~~~~~~~~~~~~~
Jess Mitchell
Boston, MA, USA
Project Manager / Fluid Project
jess at jessmitchell.com
/ w / 617.326.7753  / c / 919.599.5378
jabber: jessmitchell at gmail.com
http://www.fluidproject.org
~~~~~~~~~~~~~~~~~~~~~~




On Mar 30, 2010, at 7:50 PM, Colin Clark wrote:

> Hi Bruce,
> 
> Really good feedback. This is definitely a demo we can improve on. Instructions are a good first start, but I think the simple nature of the demo probably doesn't show the various affordances for editability we've built into the component.
> 
> I've filed a bug for this particular issue:
> 
> http://issues.fluidproject.org/browse/FLUID-3576
> 
> Colin
> 
> On 2010-03-30, at 2:13 PM, Bruce Smith wrote:
> 
>> There are no instructions visible for this demo:
>> 
>> http://build.fluidproject.org/infusion/demos/inlineEdit/simple/demo.html
>> 
>> See attached screenshot for what it looks like.
>> 
>> I'm using Firefox 3.6.2, Mac OS 10.5.8, and the NoScript plugin, but NoScript reports it is not disabling anything on this site (and I believe it, since the demo does work once I learn how to use it).
>> 
>> Maybe the lack of instructions is intentional, but I could not get it to work until I read some archived mailing list posts, which led me to try the tab key. Before reading that I was not able to edit anything (clicking on bold words and typing did nothing, and nothing else I thought of trying worked), and there were no error messages. 
>> 
>> After trying some more, I realized that for most bold words, hovering over them highlighted them, and clicking there made them editable -- but not for the only ones I tried at first, namely the word "bold" itself in the lines that say "The words in bold are editable"! I guess I only tried those specific bold words, but that was enough to make me think it was "not working". (And indeed the claim that all the bold words are editable is wrong.) So this error is amusing in hindsight, but IMHO it needs fixing on the page, either by making those words not bold or (preferably) by making them editable. (And adding some instructions would be a good idea as well.)
>> 
>> - Bruce Smith
> 
> ---
> Colin Clark
> Technical Lead, Fluid Project
> http://fluidproject.org
> 
> _______________________________________________
> Infusion-users mailing list
> Infusion-users at fluidproject.org
> http://fluidproject.org/mailman/listinfo/infusion-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://fluidproject.org/pipermail/infusion-users/attachments/20100405/cdac50d9/attachment.html>


More information about the Infusion-users mailing list