[Infusion-users] Quesion on File Uploader from Infusion 1.1.2

Colin Clark colinbdclark at gmail.com
Tue Nov 24 20:10:30 UTC 2009


Hi Justin and Cindy,

Yes, that seems to be the problem. I tried the test file on a server  
and it ran great. Running locally off the file system, I had to update  
my Flash permissions before I could get it to run.

Uploader includes a README file that explains how to configure your  
Flash permissions for testing on the local file system:

http://source.fluidproject.org/svn/fluid/infusion/trunk/src/webapp/components/uploader/ReadMe.txt

Here are the relevant steps:

1. Open your browser
2. Browse to: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html
3. In the Flash Settings panel, click "Edit locations..."
4. Select "Add location..."
5. Click "Browse for folder..."
6. Select the local /src/webapp/lib/swfupload/flash/ directory that  
contains the swfupload.swf file
7. Restart your browser

Let us know if this solves your problem, Cindy.

Colin

On 24-Nov-09, at 2:52 PM, Justin Obara wrote:

> Hello,
>
> Are you running those pages, that don't work, locally off your file  
> system or through a server?
> If you are running them locally you may have to update your flash  
> permissions.
>
> http://wiki.fluidproject.org/display/fluid/Enabling+Uploader+on+Local+File+Systems
>
> - Justin
> On 2009-11-24, at 2:36 PM, Cindy Qi Li wrote:
>
>> Thanks, Justin.
>>
>> The demo in infusion library gives same problem in firefox and IE:  
>> "Browse Files" button does not pop up the file selection box.
>>
>> fluidproject.org demo works fine though on both firefox and IE.
>>
>> ----- Original Message -----
>> From: Justin Obara
>> To: Cindy Qi Li
>> Cc: infusion-users at fluidproject.org
>> Sent: Tuesday, November 24, 2009 2:27 PM
>> Subject: Re: [Infusion-users] Quesion on File Uploader from  
>> Infusion 1.1.2
>>
>> Hi Cindy,
>>
>> Are you able to run the demo from inside your checkout of 1.1.2? It  
>> should be located in src/webapp/demos/uploader/html/uploader.html
>>
>> - Justin
>>
>> On 2009-11-24, at 11:24 AM, Cindy Qi Li wrote:
>>
>>> Hi,
>>>
>>> The multi-file uploader stops working after I upgraded our  
>>> infusion library from 1.1.0 to 1.1.2. "Browse Files" button no  
>>> longer gives me the popup file selection box and no javascript  
>>> error is reported from firebug.
>>>
>>> So, I grabbed the file uploader demo, saved into a test html,  
>>> modified a bit to point to my local infusoin 1.1.2 library, still,  
>>> it doesn't work at both firefox and IE explorer. Can someone help  
>>> me to see what I missed out? Thanks.
>>>
>>> The demo I get the code from:
>>> http://fluidproject.org/releases/1.1.2/demos/uploader/demo.html#normal
>>>
>>> Attached is my test script.
>>>
>>> Cindy from ATutor team
>>> <test.html>_______________________________________________
>>> Infusion-users mailing list
>>> Infusion-users at fluidproject.org
>>> http://fluidproject.org/mailman/listinfo/infusion-users
>>
>>
>
> _______________________________________________
> Infusion-users mailing list
> Infusion-users at fluidproject.org
> http://fluidproject.org/mailman/listinfo/infusion-users

---
Colin Clark
Technical Lead, Fluid Project
http://fluidproject.org




More information about the Infusion-users mailing list