Infusion 1.5 docs: Upgrade tutorials?

Justin Obara obara.justin at gmail.com
Thu May 8 13:48:35 EDT 2014


I agree that we should try to get those upgrade docs written, at the very least for UIO.

Thanks
Justin
On May 8, 2014, at 10:36 AM, Cheetham, Anastasia <acheetham at ocadu.ca> wrote:

> 
> Yesterday's docs sprint prompted me to think about whether or not we need any upgrade tutorials for this release: Instructions for people upgrading from 1.4 to 1.5, in cases where the APIs have changed. With respect to the components, most of our changes have maintained backward compatibility, but there are exceptions.
> 
> As a quick-and-dirty test, I hacked together the latest master with the 1.4 versions of the demos, to get an idea of what would happen if an integrator using the components simply dumped in version 1.5 without changing their code. The results are summarized here:
> 
>    http://wiki.fluidproject.org/display/fluid/API+Changes+Since+1.4
> 
> (The bottom of this page – the Notes section – was started last fall, and is likely incomplete.)
> 
> Three issues appear:
> 
> 1) Duplicate instances of Inline Edit with TinyMCE don't work.
> 2) The Pager demo is not working (haven't yet established exactly why).
> 3) UIOptions doesn't work.
> 
> My question is: Should we create "Upgrading to 1.5" tutorials before we release 1.5?
> 
> Personally, I think we need such documentation for UIO at the very least. I'm not sure about the others.
> 
> What do people think?
> 
> -- 
> Anastasia Cheetham     Inclusive Design Research Centre
> acheetham at ocadu.ca           Inclusive Design Institute
>                                        OCAD University
> 
> _______________________________________________________
> fluid-work mailing list - fluid-work at fluidproject.org
> To unsubscribe, change settings or access archives,
> see http://lists.idrc.ocad.ca/mailman/listinfo/fluid-work



More information about the fluid-work mailing list