Fwd: Fluid Demos Broken in Chrome

Clark, Colin cclark at ocad.ca
Mon Jul 4 16:57:59 UTC 2011


Hi everyone,

Jeff Cross from Unicon stumbled across an interesting bug with our demo portal in Chrome. This happens only when running the portal from the local file system. It looks like Chrome has tightened up their same origin policy rules for the local file system, making it similar but possibly more restrictive than Firefox.

I've filed a bug for the issue:

http://issues.fluidproject.org/browse/FLUID-4321

Should it be a blocker for 1.4?

Colin

Begin forwarded message:

> From: Jeffrey Cross <jcross at unicon.net>
> Date: July 1, 2011 7:01:19 PM EDT
> To: <cclark at ocad.ca>
> Cc: Gary Thompson <gary at unicon.net>
> Subject: Fluid Demos Broken in Chrome
> 
> Hi Colin,
> I'm Jeff Cross, I work with Gary at Unicon and am getting up to speed on Fluid. I ran into an issue when running the demos locally in Chrome, and didn't see an existing issue at issues.fluidproject.org. 
> 
> When I open any demo, such as pager, here is what my screen looks like (Web Inspector is open at the bottom so you can see javascript errors). It looks like a crossdomain issue, even though all the resources are local. Perhaps it's just a Chrome bug. Running Google Chrome 12.0.742.112.
> 
> Thanks! - Jeff
> 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen shot 2011-07-01 at 3.26.26 PM.png
Type: image/png
Size: 142333 bytes
Desc: Screen shot 2011-07-01 at 3.26.26 PM.png
URL: <http://fluidproject.org/pipermail/fluid-work/attachments/20110704/6e381c6e/attachment.png>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ATT00001.txt
URL: <http://fluidproject.org/pipermail/fluid-work/attachments/20110704/6e381c6e/attachment.txt>


More information about the fluid-work mailing list