API changes in 1.3: Inline Edit

Lam, Mike mlam at ocad.ca
Thu Nov 4 14:07:08 UTC 2010

Yes, both of the "editModeToolTip" and "displayModeRenderer" variables will need to be renamed.   I'll create a patch for this shortly.

The "displayModeRenderer" is a style used to create a solid blue border surrounding the displayModeContainer.   The displayModeContainer is a wrapper element around both the display text and the textEditButton.   We created this wrapper to have better styling control as we wanted to treat the display text and textEditButton as one unit on the UI.  


From: Justin Obara [obara.justin at gmail.com]
Sent: November 4, 2010 9:17 AM
To: Colin Clark
Cc: Lam, Mike; Cheetham, Anastasia; Fluid Work
Subject: Re: API changes in 1.3: Inline Edit

> Can you describe what the "displayModeRenderer" style does? I'm wondering if we've got a naming issue here? It's hard to imagine what a "renderer" is in terms of how it looks or should be styled in the DOM. Is it actually something else, like a container for Inline Edit's display mode?

I'm pretty sure that this is a problem with the name. We had changed a lot of displayModeRenderer references to displayModeContainer. This should probably be changed to something else as well. Mike can you confirm?

Also, I think the editModeTooltip is misnamed in the strings bundle. Through the rest of the code we have stopped refering to this element as a tooltip, but rather instruction text.

>    strings: {
>        textEditButton: "Edit text %text",
>        editModeToolTip: "Press Escape to cancel, Enter or Tab when finished."
>    }

- Justin

More information about the fluid-work mailing list