API changes in 1.3: Inline Edit

Justin Obara obara.justin at gmail.com
Thu Nov 4 13:17:01 UTC 2010

> Can you describe what the "displayModeRenderer" style does? I'm wondering if we've got a naming issue here? It's hard to imagine what a "renderer" is in terms of how it looks or should be styled in the DOM. Is it actually something else, like a container for Inline Edit's display mode?

I'm pretty sure that this is a problem with the name. We had changed a lot of displayModeRenderer references to displayModeContainer. This should probably be changed to something else as well. Mike can you confirm?

Also, I think the editModeTooltip is misnamed in the strings bundle. Through the rest of the code we have stopped refering to this element as a tooltip, but rather instruction text.

>    strings: {
>        textEditButton: "Edit text %text",
>        editModeToolTip: "Press Escape to cancel, Enter or Tab when finished."
>    }

- Justin

More information about the fluid-work mailing list