API changes in 1.3: Inline Edit
colinbdclark at gmail.com
Thu Nov 4 10:41:07 UTC 2010
Hey Mike and Anastasia,
Thanks for the great summary of changes in Inline Edit. A few minor comments inline...
On 2010-11-03, at 4:18 PM, Lam, Mike wrote:
> new styles:
> instructionText: "fl-inlineEdit-instructionText", // New in v1.3
> textEditButton: "fl-inlineEdit-text", // New in v1.3
> displayModeRenderer: "fl-inlineEdit-wrapper", // New in v1.3
> inlineBlock: "fl-inlineEdit-inlineBlock", // New in v1.3
Can you describe what the "displayModeRenderer" style does? I'm wondering if we've got a naming issue here? It's hard to imagine what a "renderer" is in terms of how it looks or should be styled in the DOM. Is it actually something else, like a container for Inline Edit's display mode?
> Functions moved to public namespace
> Many functions were moved into the public "fluid.inlineEdit.*" namespace that weren't there before. These are *not* public functions on the component's 'that.' I think they're probably in the class of "things that aren't actually meant for public use." They include event binding functions, view accessor setup functions, etc.
Well-factored components typically consist of a number of free functions hanging off the public namespace of the component. This is part of the essential composability of Infusion--users should be able to override our implementations with their own versions, while still having access to the buildings blocks we used to create the default implementation.
Can you enumerate the various functions you've moved into the public namespace, and elaborate on why you think they're "things that aren't actually meant for public use?" I'd encourage us to either stretch our assumptions about what might be fit for public usage, or--if these functions really aren't suitable for anyone to use--remove them from public view. The former is, of course, preferred.
Technical Lead, Fluid Project
More information about the fluid-work