Naming for the Screen Navigation Component

Jacob Farber jacob.farber at
Tue Jul 14 18:25:02 UTC 2009

Hi Everyone,
As more material is built for the component currently named "Screen Navigation Component", I'm finding it necessary to change it to something more appropriate. I think it's a good idea to rename this component now, to avoid a large and intimidating refactoring down the road.

To recap, the Screen Navigation Component  is a small component for the mobile device to watch for events, load content as needed, and transition between screens of content as users expect it to happen on their device.

Any ideas? I'm thinking:
Screen Manager
Mobile Navigator
Screen Navigator
Mobile Content Navigator
Mobile Content Manager

Thanks for any input,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fluid-work mailing list