reminder that I'm hoping for a code reveiw

Justin justin.obara at
Mon Aug 17 14:37:30 UTC 2009


I've looked over some of your commits, please see my comments below.


the code for checkElementArray and unCheckElementArray seem to be very  
similar. You could probably abstract that out into a general function  
that is called with different parameters
This is one of those things I thought about a while ago, but forgot  
about. The onModelChange event should probably be renamed to  
afterModelChanged or something like that.


What is the strategy going forward for  
fluid.customBuild.demo.completeFluidInfusionData. It probably  
shouldn't pull data in from builder.js but have some test data within  
the tests directory, or will this be pulling in some live data in the  
Depending on the above, you may want to look into not having the  
module indexes hardcoded for your tests.

It's looking good. Hope the feedback helps.

- Justin

On 14-Aug-09, at 3:44 PM, Laurel A. Williams wrote:

> Hi all,
> I'm following up from emails July 29th and August 5th requesting  
> code reviews.
> Now that the release is done, I'm hoping for code reviews to the  
> unit tests and of my small changes to the customBuild js as well.  
> I'm eager to start in on it again after a small QA assignment on  
> another project but would welcome comments before I start to muck  
> around with the code yet again. Please let me know if a reviewer  
> code tour would help.
> Thanks!
> Laurel
> < 
> laurel_williams 
> .vcf>_______________________________________________________
> fluid-work mailing list - fluid-work at
> To unsubscribe, change settings or access archives,
> see

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fluid-work mailing list