fluid infusion uploader - postParams and meta info

Colin Clark colin.clark at utoronto.ca
Fri Apr 3 15:46:46 UTC 2009


On 31-Mar-09, at 4:35 PM, Aaron Brown wrote:
> Add setPostParams and addPostParam to the API.

Makes sense.

> Also, "addPostParam" is perhaps a misnomer since in swfupload.js it's
> just a hash value assignment operation, so it will update the value if
> the key exists, or add the key/value if not.  Note that, if I remember
> the code correctly, the swfupload setPostParams function does a  
> complete
> replacement of the existing post_params hash with whatever you give  
> it.
> In that sense it is *not* like a normal hash assignment - the new keys
> won't be mixed in with the old, the old key/values will be erased.
> Not that I'm recommending another semantics discussion thread for  
> this,
> but when fluid provides public accessors to the underlying swfupload
> functions, it may be worth using some more fluid-like naming scheme
> instead of borrowing directly from the existing functions.

Yeah, this is a good point. We're inevitably going to have to look at  
the API that SWFUpload provides for us and ensure we expose it in a  
sufficiently general and flexible way. The idea of the UploaderManager  
abstraction in Uploader's architecture is to enable alternative  
strategies for doing multi-file uploading. I've sketched out a  
GearsUploadManager, and one can also imagine an HTML5UploadManager for  
Safari 4's new multi-file support.

When code freeze for Infusion 1.0 lifts, we'll circle back to this and  
make a complete decision, but I think your advice is great. I'll link  
this discussion to the JIRA ticket, too, so we don't forget about it.

Thanks again,


Colin Clark
Technical Lead, Fluid Project
Adaptive Technology Resource Centre, University of Toronto

More information about the fluid-work mailing list