Summary of API renaming for 1.0

Colin Clark colin.clark at
Wed Apr 1 04:12:15 UTC 2009

Hi all,

After much discussion on list, we met in the IRC channel this evening  
to talk through some of the API naming suggestions for the Infusion  
1.0 release. Here's what we decided:

1. The DARApplier is now called the ChangeApplier. It has two public  
      * requestChange()
      * fireChangeRequest()

2. fluid.assembleSuperModel() has been renamed to fluid.assembleModel()

3. uploader.repairFromUpload() is now refreshAfterUpload()

Each of these are new or non-public APIs, so we haven't had to worry  
about backwards compatibility. The only change that may affect users  
is fluid.findKeyInObject(), which we're now calling  
fluid.keyForValue(). We've left the old method in and marked it as  
deprecated, saving our users the pain of API renaming.

We also decided to leave UIEnhancer as-is for now. If we do introduce  
any framework-level progressive enhancement features, we'll have to be  
creative with our naming then.

You can track these changes on the JIRA ticket:


Colin Clark
Technical Lead, Fluid Project
Adaptive Technology Resource Centre, University of Toronto

More information about the fluid-work mailing list