Reorderer components' name change

Gary Thompson gary at
Wed Sep 24 22:31:24 UTC 2008

Of course, right after I post, this comes to mind:

We are calling inline edit, Inline Edit, not Inline Editor.  This scheme 
speaks to the action rather than something that does the action.  So 
maybe instead of calling it Reorderer, it should just be Reorder?

Image Reorder
Layout Reorder
List Reorder

However, we are calling upload Uploader, paging Pager, and date picking 
Date Picker.  But auto completion is Auto Complete, not Auto Completer.

So then maybe Inline Edit should be Inline Editor?


Gary Thompson wrote:
> Anastasia provides a good and (to my memory) accurate summary of 
> arriving at Layout Customizer.
> Customizer and Reorderer are both peculiar names because of the "er" at 
> the end, but that is to simply state "something that customizes" or 
> "something that reorders".  Customize is a much broader term than 
> reorder.  If I were to be particular about the name, I might think about 
> dropping both Customizer and Reorder and call it Drag and Drop, a more 
> common and recognizable term, and more descriptive of what it really 
> does -- if you discount keyboard usage.  Since we cannot discount 
> keyboard usage, I believe Reorderer to be the better label as it is more 
> descriptive than Customizer and it keeps everything in the family with 
> consistency.  So...
> Reorderer
> Image Reorderer
> Layout Reorderer
> List Reorderer
> That would be my vote.  Maybe we could ask a few Fluid-ignorant people 
> "what do you think a Layout Reorderer is?" and see if people get it.
> Gary
> Anastasia Cheetham wrote:
>> On 24-Sep-08, at 4:35 PM, Jess Mitchell wrote:
>>> Before it happens, I'd like someone who was involved in the naming  
>>> of Layout Customizer to weigh in on that name change.  More than the  
>>> other names, that one has caught on to a certain extent.  I know I  
>>> use it in conversation all the time and a good bit of our  
>>> documentation early on used reorderer and layout customizer  
>>> interchangeably (though I know that shift reflects some fundamental  
>>> code changes).
>> There was a thread on fluid-talk (I think( early in 2008 about this. I  
>> can't find the original thread, but the follow-up (definitely on fluid- 
>> talk) was titled "Renaming the Portlet Layout Manager" and it starts  
>> in Feb. with a summary of all of the suggestions.
>> I think we used 'customize' instead of 'reorder' because of the whole  
>> columns aspect - there was more to it than just changing a linear  
>> order. If I recall correctly, it was Erin that suggested the name?
>>>  Is there a reason to change it?
>> My understanding is that the motivation for using the word 'reorderer'  
>> is to establish consistency - to have all of the different flavours of  
>> reorderer use the form of "XXX Reorderer"
> _______________________________________________
> fluid-work mailing list
> fluid-work at

More information about the fluid-work mailing list