Reorderer components' name change

Colin Clark colin.clark at
Wed Sep 24 18:19:43 UTC 2008

Hey all,

On 24-Sep-08, at 2:06 PM, Anastasia Cheetham wrote:
>> This is a really good question that gave my mind pause the other day
>> when I thought of it.  Anastasia -- what do you think would be best
>> from the user-of-code perspective?
> I think it would be confusing to users if the names were not
> consistent. For the most part, everything else *is* consistent. To use
> the list reorderer, you call reorderList(); to use the inline edit,
> you call inlineEdit(); to use the image reorderer, you call  
> lightbox()??

I totally agree with Anastasia. API confusion sucks.

API change also sucks. In the spirit of slowing our rate of change in  
the APIs, I'd like to keep the legacy APIs in there--marked as  
deprecated--for the next several releases.

An alternative approach would be to provide an optional JavaScript  
file that offers backwards-compatibility for such API changes. This is  
very much inspired by John Resig's approach to API change in jQuery.

Any preferences, one way or another?


Colin Clark
Technical Lead, Fluid Project
Adaptive Technology Resource Centre, University of Toronto

More information about the fluid-work mailing list